Error in ext_vendor